Kirx' Blog -

Various ADM Template to control Microsoft Application Virtualization Clients by Group Policy Objects (GPOs)

June 16, 2010

This article has been superseeded by

The old version is:



Posted in App-V, Client, Tools

Applying App-V GPOs may prevent App-V Client 4.5/4.6 upgrade installation

June 1, 2010
Leave a Comment


When you try to upgrade a Client from SoftGrid (4.1/4.2) to App-V 4.5 or 4.6 on a machine that is pre-configured for the new version, you recieve an error:

“unable to set security descriptor on global package file(s), error=0”

The installer rolls back.

This happens if you apply GPOs or a configuration .Reg File to the client before the upgrade. Therefor: Do not apply any App-V 4.5/4.6 settings to a client befor the upgrade.


Posted in App-V, Client
Tags: ,
%d bloggers like this: